找回密码
 注册成为天翎用户
楼主: ztj820807

[其他] tomcat自己停掉

[复制链接]
david 发表于 2013-12-23 13:50:52 | 显示全部楼层
本帖最后由 david 于 2013-12-23 13:57 编辑

把你们JVM中的
  1. -Xms1024m -Xmx1024m -XX:PermSize=512M -XX:MaxPermSize=512M -XX:+UseConcMarkSweepGC
复制代码
调整为
  1. -Xms1280m -Xmx1280m -XX: PermSize=256M -XX:MaxPermSize=256M -XX:+UseConcMarkSweepGC
复制代码
试试,如果无法启动请降低两个1280的值(如果可以正常启动,也可以适当加大两个1280的值,找个平衡点)。有问题再沟通。
 楼主| ztj820807 发表于 2013-12-25 15:13:57 | 显示全部楼层
我设置了,但还是会自己停啊
sophie 发表于 2013-12-25 15:18:31 | 显示全部楼层
您好,之前您停止原因是内存益处,如果您说您现在设置了,但是还是会停,请提供一下您的日志。
david 发表于 2013-12-25 15:21:49 | 显示全部楼层
嗯,不要仅给片段,把整个日志贴上。或者直接把日志发给我。
 楼主| ztj820807 发表于 2013-12-25 15:40:12 | 显示全部楼层
hs_err_pid6468.chm (55.67 KB, 下载次数: 372)
sophie 发表于 2013-12-25 15:48:28 | 显示全部楼层
好的,本地看一下,稍后会跟进。
david 发表于 2013-12-25 15:59:06 | 显示全部楼层
本帖最后由 david 于 2013-12-25 16:04 编辑

请楼主到%JAVA_HOME%\bin目录下运行jconsole,选择tomcat的进程,如果jconsole检测不到tomcat进程,需要在tomcat的启动脚本加入以下参数
-Dcom.sun.management.jmxremote.port=1090 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=false
然后用jconsole监控远程进程,地址:localhost 端口:1090,待jconsole正常监控十几分钟以后截图上来,类似以下截图。楼主贴上“内存”、“线程”、“类”和“vm摘要”的截图。

111.png
 楼主| ztj820807 发表于 2013-12-25 18:02:46 | 显示全部楼层
远程我怎么连不上呢,报错:Connection refused connect

能不能说详细点
david 发表于 2013-12-25 18:30:49 | 显示全部楼层
本帖最后由 david 于 2013-12-25 18:32 编辑

运行jconsole
112.png

如果抓不到本地进程,需要修改tomcat启动参数,具体参数17楼已经给了

111.png

可实现监控

113.png
 楼主| ztj820807 发表于 2013-12-26 15:35:14 | 显示全部楼层
1.rar (318.92 KB, 下载次数: 374)

本版积分规则

手机版|天翎MyApps技术社区 ( 粤ICP备11093750号 )

GMT+8, 2026-9-27 17:28

Powered by Discuz! X5.0

© 2001-2026 Discuz! Team.

快速回复 返回顶部 返回列表